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Chapter 1      Downloading the ZCO Installation File
This chapter includes information about prerequisites for installing Zimbra™ 

Connector for Microsoft® Outlook® (ZCO), and how to download the ZCO 
installation file. 

Topics in this chapter include:

ZCO Overview

Server and Client Requirements

Downloading the ZCO Installation File

ZCO Overview

With ZCO, users can use Microsoft Outlook 2003, 2007, and 2010 (32-bit and 
64-bit) to access the Zimbra Collaboration Server and synchronize data with 
Outlook.

Email messages, folders, tags, contacts, personal distribution lists, personal 
calendars, appointment reminders, and tasks are synchronized with the 
Outlook client. Zimbra Collaboration Server server-side configuration for 
accounts is enforced for Outlook users.

Note:   Examples in this guide refer to ZCO features using Outlook 2007. In 
Outlook 2010, equivalent ZCO features are accessed from the Zimbra 
ribbon. 

Server and Client Requirements

To install ZCO, you must first confirm your server and client requirements: 

Server Requirements

ZCO 7.1 or later will only work with servers running Zimbra Collaboration 
Server 7.1 or later. 
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Client Requirements

• For Outlook 2003 users: Client computers must have Microsoft Office 
Outlook 2003 SP3 or later installed.

• For Outlook 2007 users: Client computers must have Microsoft Office 
Outlook 2007 SP2 or later installed. 

• For Outlook 2010 users: 32-bit and 64-bit are supported. 

Note:   “Click to run” versions of Outlook 2010 are not supported.

Downloading the ZCO Installation File 

The ZCO installation file is accessible from the Zimbra Web Client (ZWC) 
administration console or the downloads/index.html page.

To download the ZCO .msi installation file:

1.  From the Zimbra administration console, click the Downloads link on the 
upper right.

2.  Select the ZCO download file appropriate for your version of Outlook, either 
the 32-bits or 64-bits Zimbra Connector for Outlook. This is the .msi file 
required for ZCO installation.

Download the .msi file and user instructions so that you can easily deploy 
these files to your users. For example you can copy the .msi file to a 
directory or URL that users can access and then instruct users how to 
download the file, or you can use group deployment software. 

Note:   Users must have temporary administrator privileges on their computer 
to install ZCO. 
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Alternatively, you can download the installation file from 
http://{example.com}/downloads/index.html (with “example” being your 
Zimbra server name). 

Select the ZCO download file (32 or 64-bit) appropriate for your version of 
Outlook. Download the file so that you can easily deploy the file to your 
users. Users must have temporary administrator privileges on their 
computer to install ZCO. 
Zimbra Collaboration Server ZCS 7.1       7
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Chapter 2      Pre-Configuring and Customizing the ZCO Installer
This chapter includes information about how to pre-configure and customize 
the ZCO .msi installation file.

Topics in this chapter include:

Pre-configuring and Customizing the ZCO .msi File

Additional Customization of the ZCO .msi File

Disabling the Auto-Upgrade Feature

Pre-configuring and Customizing the ZCO .msi File

When ZCO is installed, the only information needed to complete the 
installation is the ZCS server name and whether to use a secure connection. 
Users enter this information when they create the default profile during ZCO 
installation, or you can customize the ZCO .msi file with this information. After 
installation, individual users then only need to use their email address and 
password to start using ZCO.

To customize the installer to add the server name and set the secure 
connection option, you modify the ZmCustomizeMsi.js file. This Java script file 
runs under the Windows Scripting Host and can be found in the Zimbra 
download directory on the administration console. 

Note:   To see a complete list of customization options, type 
ZmCustomizeMsi at the command line prompt and press enter.
Zimbra Collaboration Server ZCS 7.1     9
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1. From the administration console, Copy the Zimbra Connector for Outlook 
MSI Customizer (ZmCustomizeMsi.js) file and the Zimbra Connector for 
Outlook (ZCO .msi) file to a computer running the Windows platform.

Note:  The ZCO .msi file name is different from the example shown here. 
Note the exact file name when you download it.

2.  Open the Windows Command Prompt and go to the directory where the 
ZmCustomizeMsi.js file is saved. For example, if it is saved in the temp 
folder on your C drive, you would type cd c:\temp. 

3.  Open Command Prompt and type, all on one line:

cscript ZmCustomizeMsi.js <path/msi-filename> -sn 
<servername.com>-sp <port> -ssl <1 | 0>//nologo

Description of command input:

• ZmCustomizeMsi.js. The name of the js file.

• <path/msi-filename>. Directory path and the ZCO .msi file name. Verify 
the exact name of file.

• <servername.com>. Zimbra server domain name (DNS) to be 
configured in the .msi file 

• <port>. Port number to be configured. For non-secured connections, 
the default is 80. For secured connection, the default is 443. Your 
configuration can be different. 
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• <1 | 0>. Whether User Secure Connection should be checked. Enter 1 
for the secure connection using a HTTPS connection or enter 0 to use a 
HTTP connection. 

Press Enter and the ZCO .msi file is modified. 

Example :

cscript ZmCustomizeMsi.js ZimbraOlkConnector.msi -sn 
server.example.com -sp 443 -ssl 1 //nologo

4.  To verify that the modification is correct, you can run the .msi installer and 
create a dummy profile. The Zimbra Server Configuration Settings dialog 
should include the server name, server port, and the check box marked/
unmarked.

Once you have checked the modified .msi file, you can deploy it to users. 
Users must have temporary administrator privileges on their computer to 
install ZCO.
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Additional Customization of the ZCO .msi File

You can make additional changes to the .msi file before users install ZCO to 
modify the following functionality:

 Set the password rule to require users to log in every time they retrieve 
their email. 1 means that the encrypted password is saved in their profile 
(default). Users do not need to enter their password when they open ZCO. 
0 means that the password is not saved. Users are prompted to enter their 
passwords whenever they sync to the server.

• To set the password rule, enter as -pw <1|0>

 GAL sync mode. 2 to disable GAL sync. 1 to make GAL sync a manual 
option only. 0 for GAL syncs to occur automatically every x days. The 
interval is controlled by the -gsr switch below. The default is every 30 days. 
Note that with this option, users can also sync the GAL manually.

• To set GAL sync mode, enter as -gsm <2|1|0>

 Set the interval for the automatic sync to GAL.The sync consists of a full 
sync and interval syncs. 

• To set the delta GAL sync in minutes, enter as 
-gsd <interval>

• To set how often to resync the GAL in days, enter as -gsr <interval>

 Where sync failure notifications are saved. 1 to create sync failure 
messages only in the sync Issues folders. 0 to create the sync failure 
messages in the sync issues folders and in the user’s Inbox.

• To create sync failure message in the sync folder and/or the Inbox 
folder, enter as -ifo <1|0>

Disabling the Auto-Upgrade Feature

When a user launches Outlook, ZCO checks the Zimbra server for a newer 
version of ZCO. If a newer version is available, the user is alerted with a dialog 
that states “A new version is available on the server”. The user has the option 
to “Upgrade”, “Skip this Version” or “Never Upgrade”. If the user selects to 
upgrade, a dialog displays “Server update downloaded successfully” and the 
user then selects to “Exit Outlook & Upgrade”. 

As an administrator, you can choose to disable the auto-upgrade feature and 
eliminate the option for the user to upgrade. To disable this auto-upgrade 
feature, you can customize the .msi file, ZmCustomizeMsi.js, by using the 
--disable-autoupgrade option in the script. This allows the repackaging of the 
ZCO .msi file to disable the auto-upgrade feature. 
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Chapter 3      Installing ZCO
This chapter provides information about what server configuration information 
the user needs to install ZCO, what takes place when ZCO is installed on 
individual computers, and what happens during the initial synchronization of 
ZCO and Outlook.

Topics in this chapter include:

Installation Prerequisites

Installing ZCO on Individual Computers

Initial ZCO Synchronization with Outlook

ZDB Configuration Options

Installation Prerequisites

If you did not modify the .msi file, as described in Chapter 2, Pre-Configuring 
and Customizing the ZCO Installer, the user will need the following server 
configuration information during the installation process. Be sure to provide 
this information to your user before they install ZCO to complete the 
installation:

 Zimbra server domain name (DNS).

Note:  If your port number is not 80 or 443, your users will need to include 
the port number when they provide the server name. The server 
should be entered in the form of example.domain.com:<port>

 Whether to select to Use Secure Connection (SSL). This feature is used 
to establish a secure connection to that port.

 The user’s complete email address and email password.
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Installing ZCO on Individual Computers

It only takes a few minutes for users to install ZCO on their computers and 
configure the connection to the Zimbra server. In order for the user to do this, 
you must provide the user with temporary administrative privileges and server 
configuration information, as described in Installation Prerequisites on page 
13.

The user’s Zimbra account is also created during installation, but no specific 
changes are required on the Zimbra server. Installing ZCO creates a mail 
profile named Zimbra and designates it as the user’s default profile in Outlook. 

This does not remove any previous profiles/accounts. Previous profiles can be 
viewed by navigating to Start>Settings>ControlPanel>Mail>Show Profiles. Mail 
profiles can combine a Zimbra account with an IMAP, Exchange, or POP 
account. Select Add on the Show Profiles dialog and follow the prompts to 
add a new email account. 

Note:   You cannot add more than one Zimbra account to a profile. You can 
customize the name of the profile created during the installation using 
the “profile name” customization option available from the installation 
file.

For detailed steps and more information about the ZCO installation process, 
see the Zimbra Connector for Microsoft Outlook User Guide.

Initial ZCO Synchronization with Outlook

The first time a user open Outlook after ZCO is installed, their Outlook mailbox 
must synchronize with the Zimbra server. If users have been using the Zimbra 
Web Client and have email messages, chat archives, folders, tags, signatures, 
contacts, personal distribution lists, personal calendars, appointment 
reminders, and/or tasks on the Zimbra server, this information is synchronized 
with their Zimbra profile in Outlook. The initial synchronization can last a few 
minutes or longer, depending on the size of the mailbox being synchronized.

If users create the default Zimbra profile, their synchronized data is saved in 
the zimbra.zdb file located in the user’s Local Settings\Application 
Data\Microsoft\Outlook folder.

Users can click Tools>Send/Receive>Send/Receive All (shortcut key F9) to 
update Outlook and the Zimbra server with changes made since the last 
synchronization. 

Important:  When the Zimbra server is restored from a Zimbra backup 
session, users must perform an initial synchronization with the Outlook client 
when they log on. 

For more information and detailed steps regarding the ZCO synchronization 
process, see the Zimbra Connector for Microsoft Outlook User Guide.
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ZDB Configuration Options

ZCO supports relocating a ZDB file (also known as a roaming profile), ZDB file 
compaction, and migration of ZDB profiles. 

 For roaming profile and ZDB file compaction, you must be logged in on the 
user’s account to configure their ZDB settings. Further instructions for 
configuring a user’s ZDB settings are in the Zimbra Connector for Microsoft 
Outlook User Guide.

 For migrating ZDB profiles, use the following instructions.

Migrating ZDB Profiles

You can migrate ZDB profiles, including user files and settings, from one 
system to another as described in this section.

1. Install ZCO on machine A and on machine B.

2.  On machine A, create a profile and synchronize it. 

3.  Shutdown Outlook.

4.  On machine A, save the profile settings from the registry to a file (look 
under HKEY_CURRENT_USER\Software\Microsoft\Windows 
NT\CurrentVersion\Windows Messaging Subsystem\Profiles).

5.  Copy the ZDB's to machine B.

6.  Import the registry settings to machine B.

7.  On machine B, make sure Outlook is set to prompt which profile to use.

8.  Open Outlook and select the copied profile. Your profiles are migrated.
Zimbra Collaboration Server ZCS 7.1       15



Zimbra Connector for Outlook Administrator Guide
 16      ZCS 7.1 Zimbra Collaboration Server



Chapter 4      Rebranding ZCO
ZCO can be configured to substitute alternative branding for the Zimbra 
strings and bitmaps within ZCO and in its installer package. With the 
substitution in place, occurrences of the “Zimbra” and “ZCS” brands within the 
product are replaced with strings supplied by the customizer, and all Zimbra 
icons and bitmaps are replaced with a generic set of images.

The substitution is achieved by changing properties in the ZCO .msi installer 
package prior to installing. A simple script is supplied, Zimbra Connector for 
Outlook Branding MSI (ZimbraBrandMsi.vbs), which can be modified as 
follows: 

1. Open the Zimbra Connector for Outlook Branding MSI script found on 
the Administration console Downloads page. 
Zimbra Collaboration Server ZCS 7.1     17



Zimbra Connector for Outlook Administrator Guide
2.  At the start of the script, replace the customizable value “Foobar” with your 
company name or value:

Brand = "Foobar"

Company = "Foobar, Inc"

DefaultProfileName = "Foobar"

AboutLink = "http://www.foobar.com/About"

DocumentLink = "http://www.foobar.com/Help"

Value Descriptions

 Brand is by far the most important setting. It provides a substitute for 
virtually all occurrences of “Zimbra” in the product. The exception to this is 
that the Zimbra copyright statement is retained in ZCO's “About” dialog. 
Any value of “Brand” other than Zimbra also triggers the substitution of 
icons and bitmaps. Maximum of 30 characters. 

 Company only appears in the .msi file's summary information (right click 
and select “Properties”) and in the Control Panel entry for the installed 
program (under “Publisher”). No character limit.

 DefaultProfileName provides a name for the default Outlook profile to be 
created as part of the installation if none already exists. Maximum of 64 
characters.

 AboutLink provides the URL which appears in the Control Panel entry for 
the installed program (under “Support Link”). No character limit.

 DocumentLink relates to the "Click here for documentation" link on the 
ZCO About dialog. This normally links to a Zimbra branded PDF document 
but can be redirected to the customizer's own web documents. Maximum of 
260 characters. 

3.  Once the script is configured, run the script on each new ZCO .msi supplied 
by Zimbra prior to installation using

  cscript ZimbraBrandMsi.vbs ZimbraOlkConnector.msi

Note:   If previously installed on the target machine, the standard ZCO should 
be uninstalled before running the newly branded installation.

4.  Your company name or value now displays throughout ZCO replacing the 
“Zimbra” brand, and the Zimbra icon is now replaced with a generic icon.

Note:   Existing Outlook profiles created using the unbranded package should 
remain usable but will show the old "Zimbra - ..." store name.
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Chapter 5      Zimbra Features in Outlook
This chapter explains ZCO features when using Outlook with ZCO installed.

Topics in this chapter include:

Zimbra Features in Outlook

Zimbra Feature Differences for Outlook Users

Note:   Examples in this guide refer to ZCO features using Outlook 2007. In 
Outlook 2010, equivalent ZCO features are accessed from the Zimbra 
ribbon. 

Zimbra Features in Outlook

Several Zimbra features are available in Outlook. Below is a list of these 
features and where they are implemented in Outlook.

 Zimbra Personas are available in Outlook under Tools > Options > 
Personas.

 Zimbra Mail Filters are available in Outlook under Tools > Zimbra Server 
Rules.

 Out-of-Office Reply can be created from Tools > Zimbra Out of Office 
Assistant. 

 Zimbra Tags are synchronized with Outlook Categories. To browse your 
email, contacts, tasks, and appointments by category, go to your Zimbra 
mail folder in the Navigation pane, and select Search Folders > 
Categorized Mail. The mail is displayed grouped by category in the 
Content pane.

 Zimbra mailbox quota can be checked using Tools >Mailbox Quota.

 To enable/disable the GAL and update the GAL, use Tools > Send/
Receive > Global Address List.

 Select/Deselect error messages to the inbox: View > Errors to Inbox.

 For troubleshooting, you can select/deselect having errors sent to the inbox 
using View > Errors to Inbox.
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 For ZCO information, select Help > About Zimbra Connector for 
Outlook.

 Sharing: In Outlook, you can access Zimbra mail folders, calendars, 
contacts, and tasks shared with you by another Zimbra user. 

Note:   Outlook Notes and Journals are not synchronized with the Zimbra 
server, therefore are inaccessible using ZCO. Also, Search folders 
created in ZWC do not synchronize to Outlook.

Zimbra Feature Differences for Outlook Users

Zimbra Collaboration Server offers account configuration by Class of Service 
and by account. When the client uses Outlook, many of the features and 
options configured for the Zimbra account are not enforced in Outlook. Only 
restrictions that are controlled by the server are enforced. 

Users can configure their own Outlook preferences. These are not 
synchronized with the Zimbra server. When you view an account’s mailbox 
from the administration console, the view is from the Zimbra Web Client and 
may not contain files in Outlook that have not been synchronized. 

Note:   When items are archived in Outlook (using Outlook auto archive or 
manually), the items are removed from the Zimbra server.

COS and Global Settings Enforced for ZCO Users

Zimbra COS features and Global Settings that are enforced include:

 Account quotas. Users can see their account quotas by going to 
Tools>Mailbox Quota. If they are close to their quota, users can use 
Outlook Archiving to save files to their computer to prevent going over their 
quota limit. Archiving removes the messages from the Zimbra server.

 Password rules including password length, age, history

 GAL access

 Address book size limit

 Email message lifetime

 Trash and spam message lifetime 

 Reject messages with specified attachment extension. You cannot disable 
attachment viewing.

 Anti-spam and anti-virus rules

 If the Maximum size of an uploaded file (KB) field is set to 0 in the ZCS 
Global Settings>MTA tab, messages sent through Outlook cannot be 
delivered.
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Chapter 6      Troubleshooting ZCO
This chapter includes information about how to troubleshoot ZCO.

Topics in this chapter include:

Repairing ZCO

Resolving Mailbox Sync Problems

Troubleshooting Options

Common Troubleshooting Issues

Repairing ZCO

You can use the same version of the ZCO .msi file to repair the ZCO software 
on individual computers. 

Note:   To find out what version of ZCO is installed, open Outlook and go to 
Help>About Zimbra Connector for Outlook.

When the .msi file is opened after ZCO is installed, it automatically opens with 
the options to repair the connector or to remove the software.
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 Repair. This will reinstall the software.

 Remove the Outlook Connector. This will remove all components, except 
for the Zimbra Profiles.

Note:   The user should not delete the existing Zimbra Profile.

Resolving Mailbox Sync Problems

In the event that a user’s mailbox cannot receive new mail, becomes out-of-
sync, or the .zdb file becomes corrupted, you can:

 Choose to force an initial sync of the user’s mailbox. To do this, have the 
user create another profile, open Outlook, and click Tools>Send/
Receive>Send/Receive All to sync with the Zimbra server.

 Set the Sync Token to an earlier Sync Token number, and attempt to resync 
the user’s mailbox. For more information on setting the Sync Token, see 
Set Sync Token on page 27.

 Have the user exit Outlook and then delete the existing .zdb file. This 
deletes all data on the user’s computer and recreates the mailbox from the 
data that is on the Zimbra server, but keeps the same profile. Restart 
Outlook once the .zdb file is deleted. 

In some cases, it may be necessary to uninstall the .msi file, delete the profile 
and .zdb file and start over. 

Important:  When the Zimbra server is restored from a Zimbra backup 
session, users should resync Outlook with the Zimbra server.
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Troubleshooting Options

If the Outlook client is not synchronizing with the Zimbra server or if Outlook is 
not working correctly, several options are available to troubleshoot the 
problem:

 Review the user’s Sync Issues mail folder for errors. This is in the Folder 
List. See Reviewing Sync Issues folders on page 24.

 If the initial sync did not work, run the .msi file again and select Repair to 
see if reinstalling ZCO resolves the problem. 

 If Outlook closes unexpectedly (e.g. with the warning “Outlook...needs to 
close”), generate core dumps for Outlook. Go to the Zimbra Wiki 
Generating CoreDump page (located at http://wiki.zimbra.com/wiki/
Generating_Core_Dumps) for directions. The core dump shows what 
Outlook was doing at the time of the crash. This file should be sent to 
Zimbra support, at support@zimbra.com.

 If Outlook is hanging, or behaving strangely, run the Logging Control tool 
that is installed when ZCO was installed. See Using Logging Control for 
Troubleshooting on page 24. Send this file to Zimbra support, at 
support@zimbra.com. 

 Remove the ZCO .msi file, delete the .zdb file and the profile, and reinstall.

 Other topics in this section include:

• Zimbra Support Toolbar on page 26

• Additional Resources on page 30

• Contacting Zimbra Support on page 30
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Reviewing Sync Issues folders

When ZCO is installed, a Sync Issues folder 
with subfolders is created in the user’s Outlook 
Folder List. If errors are found when Outlook 
syncs with the Zimbra server, a sync failure 
notification is sent to both the user’s Inbox and 
the Sync Issues folder. To turn off local failure 
notifications to the user’s Inbox, deselect 
Errors to Inbox under the View menu.

To view the Sync Issues folder, click the Folder 
List icon in the Navigation Pane. The Sync 
Issues folder is displayed in the Folder List. 
Users can tell when new messages are in these 
folders if the folder is bold and the number of 
unread messages is displayed.

If users are having problems using Outlook and 
continuously receiving errors, the messages in 
these folders should be submitted with a 
support case to Zimbra Support. These 
messages are created to help Zimbra technical 
support and engineering debug and fix errors.

Using Logging Control for 
Troubleshooting 

ZCOLogCtl.exe is installed when ZCO is 
installed. If users encounter problems when 
accessing their Zimbra accounts using ZCO, 
you can enable the logging control tool to log 
errors and events that occur while they are 
using ZCO. Logging Control should be used for 
all troubleshooting. Once you have enabled 
logging and have recreated the issue, you can 
then send this log to Zimbra for analysis.

This logging control tool is in the local ID 
directory, \Program files\Common Files\System\MSMAPI\<LCID> where LCID 
refers to the local ID of the user. For USA English, this ID is 1033.
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The following options can be specified:

 HTTP Logging. Enabling HTTP logging will log any HTTP traffic.

 Verbose Logging. Enabling verbose logging will create more detailed logs, 
but may affect performance.

 Keep Logging. When you enable this option, the logging control tool saves 
more than one backup log file. By default, only one backup log file is saved. 

 Log File Path. In this field, you can specify in what directory log files should 
be saved.

 Log File Prefix. In this field, you can specify the prefix for log files.

 Maximum Log File Size. You can indicate the maximum size of a log file. 
The default log file size is 10 megabytes. When the size of the log reaches 
the limit, the current log is set aside and a second log is created. If the log 
file size is set to 0, the size of the log file is unlimited.

When the problem has been recreated, submit a support case and include 
these logs.

Note:   Enable Logging should be unchecked to disable logging when not 
being used for troubleshooting. If logging is on continuously, 
performance may be affected.
Zimbra Collaboration Server ZCS 7.1       25



Zimbra Connector for Outlook Administrator Guide
Zimbra Support Toolbar

When ZCO is installed, the Zimbra Support Toolbar is added to the Outlook 
Views list. If users are having issues with specific emails or folders, you can 
use this toolbar to collect information to help debug the issue.

To access the Zimbra Support Toolbar, go to View>Toolbars>Zimbra 
Support. You can also access this toolbar by right-clicking the toolbar area 
and selecting Zimbra Support from the Toolbar menu. The Zimbra Support 
Toolbar is added to the Toolbar View.

The Zimbra Support Toolbar buttons are explained below.

Properties

The Show Properties button shows a subset of the MAPI properties of an 
item. Select either Message or Folder in the lower left of the MAPI properties 
dialog to view MAPI properties of a message and of the folder. You can click 
Save to File to save the MAPI properties of an item to a file.

Show Original

The Show Original button opens the source of the original item in the default 
Internet browser. The browser prompts you for the account login information 
before you can view the item. The source text includes the Zimbra Item ID, 
Folder ID, and any other information contained in the original item (such as 
tags, flags, header information, etc.).

Open By Zimbra Id

The Open By Zimbra Id button allows you to view an email, appointment, 
task or other item in Outlook by its Zimbra Id. You can find the Zimbra Id of an 
item by using the Show Original button in the Zimbra Support Toolbar, or by 
the number listed in a Local Failure Notice.
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Note:   Meeting requests cannot be opened by Zimbra Id. Drafts can be 
opened, but will sometimes generate errors when opened by Zimbra 
Id.

Set Sync Token

Important:  Be careful when setting the sync token.

The Set Sync Token button allows you to set the Zimbra Sync Token. Sync 
Tokens track the syncs between an Outlook client and the Zimbra Server. 
Sync Tokens increase in numerical value between one sync and the next. 
Setting a Sync Token to an earlier number allows you to resync any items that 
failed to sync between the Sync Token you set and the current Sync Token.

For example, if an appointment fails to sync to a user’s Outlook client they will 
receive a Local Failure Notice in their Inbox and Sync Issues>Local Failures 
folders.
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In this example, an appointment failed to sync. To resync this item and update 
the user’s Outlook client with the most information, the Sync Token must be 
set to before the request that failed. In this example, the Sync Token must be 
set to any token before 55080.

Note:   In some cases, sync failures might not be resolved unless the Sync 
Token number is set back several tokens before the failed sync. For 
example, if setting the Sync Token to 55079 still fails to sync the item, 
setting the Sync Token to 55075 might successfully sync the item.

To set the Sync Token and attempt to resync an item that failed to sync, click 
Set Sync Token in the Zimbra Support Toolbar. The Update Sync Token 
dialog opens.
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In the Update Sync Token dialog, enter the Sync Token to set. Click OK. To 
attempt to resync the item, click Send/Receive.

Advanced

The Advanced button is used to set the following:

 Connection Timeouts. Configure your HTTP connection settings. The 
default settings for connect, send, receive and option/receive are 900000 
milliseconds, or 15 minutes, although these settings are configurable.

 GAL Sync Optimizations. Set your GAL sync time, including delta sync 
interval, full sync interval, sleep time, and sleep after. The full sync default 
is 30 days, with the delta sync default being 4 hours (240 minutes). If your 
system is slow due to the sync, you can configure your system to go to 
sleep after a specified number of contacts have been synced.

 LDAP. The LDAP default is disable, although you can enable LDAP and 
enter your server name. 

 Delegate Calendar Sync. You can select to sync all calendar content, or 
select to sync partial calendar content by selecting a specified number of 
days to sync.

 Enable local rules. Check this box if you want to enable local Outlook 
rules. By default, local Outlook rules are disabled.

 Store password in the profile. Check this box if you want to store user 
passwords in their profiles. Uncheck this box if you do not want user 
passwords stored in their profile, and they will have to enter their password 
at each login.

Any changes made in the Advanced Settings dialog are made to the registry.
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Additional Resources

If your issue is not a known or common issue, or is persisting despite 
troubleshooting, you can use the following additional resources to search for 
information about your issue.

 Zimbra Forums. The Zimbra Forums, http://www.zimbra.com/forums, are 
a great place to find answers to problems and issues you may be 
experiencing. 

 Zimbra Wiki. The Zimbra Wiki has many articles and reference material 
about ZCO. Go to http://wiki.zimbra.com/wiki/Category:ZCO.

 Web Search. If you cannot find a solution to your issue through the Zimbra 
Forums, you might be able to find other resources or information using a 
Web search. 

Contacting Zimbra Support

Zimbra Support can be contacted at support@zimbra.com. To provide the 
highest level of service, please gather the following information before 
contacting support.

 Steps for reproducing the problem. You will need to include steps for 
reproducing the problem that you are experiencing.

 Log files. You will need to include logs generated by ZCO Logging Control, 
described in Using Logging Control for Troubleshooting on page 24. These 
logs should only contain logging information gathered while the problem 
was occurring.
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 Zimbra Support Toolbar output. You will need to include any relevant 
Zimbra Support Toolbar output, described in Zimbra Support Toolbar on 
page 26.

Beyond the above information, include the following information if it is relevant 
to your problem. 

 Install logs. If you are experiencing issues with installing ZCO, please 
include the install logs. You can create install logs by running the following 
command.

msiexec /i <zco-installer.msi> /lv <zco-install.log>

For example, the following command will create a ZCO install log named 
case00012345-zco-install.log.

msiexec /i  ZimbraOlkConnector-5.0.6_GA_2314_5.0.2635.6.msi /
lv case00012345-zco-install.log

 Sync error messages. If you are experiencing issues with syncing, include 
any relevant error messages. You can find sync error messages in the 
Local Failures and Server Failures folders, located in the Sync Issues mail 
folder. For more information about the Sync Issues folder, see Reviewing 
Sync Issues folders on page 24.

 Core files. If you are experiencing issues with ZCO crashing, include the 
automatically generated core files located in %temp%\zco-cores. If these 
core files have not been automatically generated, you can manually create 
a core dump using the instructions available at the Zimbra Wiki, located at 
http://wiki.zimbra.com/
index.php?title=Creating_a_Core_Dump_from_a_Running_Process_using
_WinDbg.
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Common Troubleshooting Issues

This section contains information about common troubleshooting issues, 
including:

 I received a Local/Server Failure Notice

 Outlook crashed

 My Zimbra Calendar won’t sync

 I can’t access a shared item

 My .zdb file is corrupt

I received a Local/Server Failure Notice

If errors occur when Outlook syncs with the Zimbra server (for example, a 
MIME error), Local/Server Failure messages are automatically sent to the 
user’s Outlook account. These messages are created to help you and Zimbra 
Support debug and fix errors.

Review the Local/Server Failure messages. The problem may be apparent 
and simple to resolve, such as an “out of quota” message. If you cannot 
resolve the error based on the message, submit the messages with a support 
case to Zimbra Support.

When ZCO is installed, a Sync Issues folder with subfolders is created in the 
user’s Outlook Folder List. A copy of Local/Server Failure messages is saved 
to the Sync Issues Folders. 

 To view the Sync Issues folder, click the Folder List icon in the Navigation 
Pane, or select Go > Folder List. The Sync Issues folder is displayed in the 
Folder List. You can tell when new messages are in these folders if the 
folder is bold and the number of unread messages is displayed beside the 
folder name.

 To disable failure notifications to the user’s Inbox, deselect View > Errors to 
Inbox.
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Outlook crashed

If Outlook closes unexpectedly (for example, with the warning 
“Outlook...needs to close”), look in the Windows %TEMP% directory to see if 
there is a subfolder called zco-cores. You can also generate core dumps for 
Outlook. See http://wiki.zimbra.com/wiki/Generating_Core_Dumps for 
directions. 

The core dump shows what Outlook was doing at the time of the crash. 
Submit a case with this file to Zimbra support.
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My Zimbra Calendar won’t sync 

1. Verify that the user’s account has synced.

2.  Check Local/Server Failure messages in the Sync Issues folders.

3.  Use the Logging Control Tool. Submit a case with the logging information to 
Zimbra Support.

Note:   Enable Logging should be unchecked to disable logging when not 
being used for troubleshooting. If logging is on continuously, 
performance may be affected.
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I can’t access a shared item

1. Verify that the user has accessed the calendar correctly: Open>File> Other 
User’s Mailbox. The GAL is displayed. Select the sharing user from the list. 
The shared item should sync automatically.

2.  Use the Logging Control Tool. Submit a case with the logging information to 
Zimbra Support.

Note:   Enable Logging should be unchecked to disable logging when not 
being used for troubleshooting. If logging is on continuously, 
performance may be affected.
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My .zdb file is corrupt

A user may receive a Local Failure message stating that the .zdb file is 
corrupt. If this occurs, you will need to repair the .zdb file. The .zdb file 
includes all Outlook data from the Zimbra server in .pst format: messages, 
contacts, appointments, tasks, etc. 

Use the scanpst.exe tool to:

 Repair any .zdb file that Outlook/ZCO has trouble opening.

 Repair your PST files before importing them using the Zimbra PST Import 
Wizard.

To use the scanpst.exe tool:

1. Search for it in Windows (Start>Search>For files or folders).

2.  Type the path and the file name of the personal folders (PST or ZDB) file, or 
click Browse to locate the file by using the Windows file system.

3.  Click Start.
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